Our Website Family: TunerSports.com ClubCivic.com ClubIntegra.com
Attention Acura Integra Visitor:  Remove this block by logging in above or r

Welcome to ClubIntegra.com.

A forum dedicated to the Acura Integra, including all generations. In order to post on this forum you will have to register.

Registration is free and will entitle you to other site features including access to post your Acura Integra in the member's garage, join in raffles for performance parts, etc.

To start viewing messages by generation, select the Acura Integra forum that you want to visit from the list below. Or view all Acura Integra forums.

Go Back   ClubIntegra.com - Acura Integra Forum > Acura Integra DIY / How To > How To's > Interior / Audio / Electronics Tech Archive / How To's


Please SEARCH before posting a new thread. ->
Ready to Post a New Thread/Question? ->

Radio and clock don't work

Interior / Audio / Electronics Tech Archive / How To's

Thread Tools Rate Thread Display Modes
Old 05-15-2011, 09:57 PM   #1
Registered User
Join Date: May 2011
Posts: 1
iTrader: (0)

Angry Radio and clock don't work

my radio and clock went out simotaniously, i have checked all fuses and they are fine so i dont know where else to turn. And about a month before that my horn stopped working. My car is a 1995 Acura Integra LS
Bluechoppers200 is offline   Reply With Quote
Old 06-16-2011, 05:24 PM   #2
Registered User
dmacnesa23's Avatar
Join Date: Feb 2011
Posts: 80
iTrader: (0)


fuse under the hood was the reason for mine.

dmacnesa23 is offline   Reply With Quote
Old 06-16-2011, 05:28 PM   #3
Senior Member
eiznekeM's Avatar
Join Date: Nov 2010
Location: Edmonton, Alberta, Canada
Age: 23
Posts: 528
iTrader: (0)


Originally Posted by dmacnesa23 View Post
fuse under the hood was the reason for mine.

Probably this, but double check the fuses again (the normal box), the radio and clock are on the same fuse. Make sure it's the correct rating and it's installed properly. Check all the fuses while you're at it. I only had my interior lights one go on me but when I checked them all I had two more that needed changing,
DA Squad Member #110

1992 Integra LS - Traded
1991 Integra GS - Raced, Stripped, Crushed
1992 Integra GS - 140k Driven, Stripped
1991 Integra RS - Rebuilt, Sold
1992 Integra GS - 120k Driven, Stripped, Sold
1992 Integra GS-R - Bought as Salvage, Donor
1992 Integra LS - Daily Driver
1992 Integra GS - New Project, GS-R Clone

DA owner for life!

My Thread

Originally Posted by OGstackadolla View Post
I don't stretch tires, I stretch c***s
eiznekeM is offline   Reply With Quote
Old 03-07-2013, 08:02 PM   #4
Registered User
Join Date: Mar 2013
Location: Hornell, New York
Posts: 2
iTrader: (0)


in my 95 ls i had the same problem it was working cause the smuck i bought the car from cut the car side harness and cob jobbed the aftermarket radio in it, once i wired the new harness in i had no clock or radio, did a little research and theres a 7.5amp fuse in the engine bay listed as a back up i replaced that and i once again had my radio and clock back
Thand92 is offline   Reply With Quote
Old 08-19-2013, 04:48 AM   #5
Registered User
Join Date: Aug 2013
Posts: 3
iTrader: (0)


my fuse was bad but i put the 10 amp hazard fuse in there and still nothing so i just switched back. any tips on what could be keeping my radio from turning on. ive checked all the wiring nothing is exposed and everything is connected the way it was when it was working.

Last edited by IndianaTeg; 08-19-2013 at 04:51 AM.
IndianaTeg is offline   Reply With Quote
Old 08-19-2013, 02:24 PM   #6
treeafodo's Avatar
Join Date: Jul 2011
Location: Windsor, Ontario
Age: 22
Posts: 1,350
iTrader: (2)


I had the same issue happen after taking the battery out and putting it back in. My problem was a fuse under the hood. It looked ok, but a test light proved otherwise. Replaced the fuse and it was fixed.

Edit: Just realized how old this thread was...
Lexy (Little Hobo)- From Wreck to Racecar < Click
Christian Integra Squad Member #34
Originally Posted by randomhobo View Post
the level of clean in your engine bay puts even Mr Clean to shame sir.
treeafodo is offline   Reply With Quote


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clock And Radio Resets! HELP Doctah-Jay 3rd Generation Acura Integra (1994-2001) 17 11-01-2012 05:31 PM
Clock and Radio doesn't work after installing an amp? ImElvis Interior / Audio / Electronics 10 09-01-2010 10:30 PM
clock and radio problem patquinn 3rd Generation Acura Integra (1994-2001) 3 08-10-2010 10:01 PM
Radio clock doesn't work Poison Ivy 3rd Generation Acura Integra (1994-2001) 8 07-01-2010 10:02 PM
Radio and clock don't work, please help!!! DA GSR KID 3rd Generation Acura Integra (1994-2001) 7 07-02-2009 10:48 AM

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -4. The time now is 07:14 AM.

Store News:

Latest Topics:

Store Specials:

Find this site helpful? Donations are appreciated.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Forum SEO by Zoints