Lost Power!! Help Needed!!



#1
I am at a loss here.. I have a 92 DA with B20 swap.. I am having power loss issues so I will try and give as much info as possible as to the situation. I bought this car a few months back and have been fixing the chicken sh't work on this car. The issue is continually getting worse, started as a loss of power, "bog" under holding speed. Doesn't matter what gear or what RPM.. Holding speed in gear runs great until car heats up then it'll start to sputter and lose power .. Drives fine for 3-4 sec, then bogs down "dying" until letting off the gas then back on and starts all over again. If instead of letting off I punch it, it'll pick up and haul ass. Now the strange part, car drove great but the header had a straight through crack, due to the header being welded to the exhaust pipe back to the short can Muffler (no cat, yes resonator) To fix the header a full exhaust replacement was necessary. Replaced the eBay header 4-2-1 with a DC Ceramic 4-2-1 header. A bolt in cat convert (tried bolt in test pipe too so it's not the cat) bolt on skunk 2 cat back. The INSTANT I drove after exhaust change the issue started.

Here is what I have tried so far, replaced 02 sensor, cap and rotor, plugs and wires, negative coil, checked and adjusted fuel pressure (was at 52psi now at 39) replaced the coil wires cap and rotor again but with MSD, inspected and cleaned fuel injectors, replaced pr4 ecu, tried a different p75 ecu, changed PCV valve.. Only thing missing that I can see is a breather box that the PCV hose goes to (currently goes from manifold to valve then nothing) but it was alway like that. Took it to a shop because it will throw a code RARELY code 43 BUT when check engine light on car runs perfectly.. Shop said code is Basically air fuel issue..

NOW in the last 2 days, issue happens all the time.. Used to only be under constant load in gear now it's constant load at all.. Neutral or not.. No has rough idle to almost stall but doesn't (not the rhythmic up and down of a bad TPS sensor either)

Sorry for the long post but I wanted all the info out and I have exhausted all things I can think of.. You guys are smarter than I please help!!!!
 


#2
what o2 did you replace?

If secondary then that wont cause this issue. You should look at your primary. The reason I say that is because you stated it doesnt bog when cold but does when hot. When the engine is cold it bases its AFR on the map sensor. I believe this is called open loop. Once the engine is at operating temp, it bases AFR off of the primary (upstream) o2. This is called closed loop. If the heating element in you o2 sensor is bad, it will stay in open loop which causes bogging at oper. temp. Sometimes it will throw a code and sometimes it wont.

I would start by eliminating any CELs you have. Then look into your primary o2.
 
#5
Great feedback guys! Although I am far from a noob, as such, I am far from an expert.. The reference to a CEL part? I am unaware of such a part.. I was under the impression CEL was the code 43 designation? If so, no I have not replaced.. I will also need some assistance in location of said part on the car.. Yes I have come to the same conclusion that the issue only happens once that loop changes to operation temp mode. This 92 DA is wired OBD1 and has only one o2 sensor that I can locate (connects to exhaust in the header down pipe collector area) and was replaced with the OEM replacement option from checker, I don't like using the Bosch crap. Hopefully this added information can help us narrow this bizarre issue.

Thanks!
J.
 
#7
When I google it just kicks up these forums and to replace everything I have already done.. I thought the bogging could be from lack of fuel at that stage but after it Bogs and I floor it to get it back going again.. You can literally smell it running rich just at that point.. Only has that smell on engaging after bogging.. No other time.. What I keep coming back to is it only started after fixing the exhaust.. So logic would suggest its sensor or even vacuum related even? Anyone know of a link I can find the vacuum lines diagram and sensor diagram?
 

Muckman

Not a M0derator
#8
No, I dont agree with that logic.

The key here is it runs great when at wide open throttle, correct? It only bogs when at part throttle, correct? The difference between full and part throttle is closed vs open loop. Under part throttle the Ecu operates in closed loop which means the Ecu is using feedback from the O2 sensor to adjust the fuel injection. It does not use O2 feedback at full throttle, where the engine runs fine according to you. This means the feedback is messed up and the likely culprit is the O2 sensor. Since you already replaced it the next logical question would be the long term fuel trims from the previously bad O2 sensor. You need to clear the Ecu to reset all the fuel trims. Pull the 10amp PGM-FI fuse in the engine bay fuse box and leave it out for 5 minutes (or you can just unhook the battery if you want).
 
Last edited:
#9
Ok muckman.. I REALLY appreciate your help thus far.. You have given me some extremely good advise that I highly value.. That being said.. None of it has worked sadly.. I have changed the o2 3 times now.. With 3 different brands, reset the computer (really thought that was a great suggestion) then changed out the computer for a new one, then reset THAT one as well.. I have scoured the entire engine bay for a possible broken vacuum line or disconnected sensor.. Even broke out the ol meter and tested the o2 wires in case something had shorted.. Only thing I found was the hose from the top of the purge cut-off solenoid valve to the top of the charcoal canister was disconnected.. That was it! Hopefully you have another approach or idea because I am fresh out! 3 different shops can't figure it out.. They tell me to replace the things I have already replaced! Any help would be greatly appreciated!
 
#10
Another idea that I just thought of.. If the new header was not torqued to the head correctly.. What would the effect of that be? I have not checked the shops work due to not having my own torque wrench.. I'm just grasping at straws here guys.. Not sure what else could be the issue
 

Muckman

Not a M0derator
#11
What about the fuel system? Have you replaced the fuel filter? Perhaps the pump is starting to die. The code 43 indicates the fuel system is faulty. Thats either the pump, filter, lines, injectors or regulator. Pretty simple system to debug. You said you checked pressure at idle but you dont know the pressure while driving under load. The regulator could be faulty also.
 
#12
I will get on buying the new items because at this point I am running out of things to try.. I have had pumps and regulators go out on previous vehicles and the issue seemed to be constant.. My issue seems only from the one fuel map, when running off sensors.. So I had been focused on that.. I will try a change
 
#13
I have a walbro 255 fuel pump, aem fuel rail and regulator on order.. Not sure if it's relevant.. But when replacing the PCV valve, the line runs from the intake manifold (next to the FPR vacuum line) down to the PCV valve held by a grommet in the manifold under the fuel rail. Then under the rail does absolutely nothing, doesn't go to a breather box like I thought it would, just stops right there. This is just a stock b20b, no vtec.. I know with a b20vtec you tap a barb in the blank for it.. What is the procedure for stock b20 PCV setup?
 




VigLink badge