Please help. Car does not start: No fuel, No spark

Hung

New Member
#16
Hi Prozon / hondahead505

Thanks for answering my question.

Correct, I found the main relay after searching the forum for pictures. One posted with a lot of pictures to show how to kill the main relay for car theft prevention.

I checked all the fuses under the dash, out under the engine hood. All looks good.

I shall check the ground cable in the morning.

How can I test the ECU to find if itself is bad ?

Thanks

Hung
 
#17
Check your igniter in your distributor. My teg did that recently engine starting jolting then died completely on me and had to tow it. the shop said my ignitor in the distributor went out, was like 400 to fix but runs good now.
 
#18
Can't you get a whole distributor for less than that???!

My guess is the ground cable, seeing as how there is now fuel or spark. The igniter only covers spark.
 
#20
That's what I said. :D
 

Hung

New Member
#21
Hi bjanosz62391, Prozo,

Thanks for your help

I checked the ground cable where the engine thermostat is. It looks intact, No break. I checked all other grounds ( There are about 4 grounds at different location), they looks good also.

Is there any way I can test the ECU to see if it work or not ?

Thanks

Hung
 
#24
Fuel injector.... sensor.......????
There are relays to turn it on.. and the ECU controls all of it.
 
#25
Fuel injector.... sensor.......????
There are relays to turn it on.. and the ECU controls all of it.
I am having the same problem i have no spark or fuel and my ecu fuse is good but its not powering up and i discovered that both my main relay and my ignition switch had fried. i replaced them both and am still having a no start issue just like hung here is what can someone tell me any help would be appreicated